ST8000DM003 Can't Modify System File 93

Moderator: Dmitriy_TS

User avatar
Posts: 462
Joined: 15.12.15
Reputation: 14 / (141)

ST8000DM003 Can't Modify System File 93

Postby DataMedics » 12.07.18, 17:02

So I've got here an 8Tb drive model ST8000DM003 which came in with failed heads. The heads were replaced with a perfect donor set from an exact match drive. The only difference between the two is three days on the date of manufacture.

After swapping the heads and unlocking the ROM this is what I was getting in terminal:

Code: Select all

Tech Unlock Handshake: 0x33693C60

Rst 0x0100MAF00550001   
No HOST FIS-ReadyStatusFlags 0002A1A1

I could work in terminal, but ATA registers stayed stuck at BSY. I tried numerous times to modify System File 93 and disable the media cache and other unnecessary functions but the changes never took no matter how many times I tried it.

Heads were re-tested back in the donor and they're 100% functional still, so I know it's not any damage to the heads.

Finally, having run out of options, I followed the Ace method here: ... error.html

(there was one NRG entry, but I can deal with the partial access issue later)

Now after doing the translator regen (which took 7-8 min and spit out a number of errors) the ATA registers do go to DRD DSC but the drive still won't ID or allow anything to work over ATA, I can still only work in terminal. Modifying System file 93 is still not working as well. On startup the drive is spitting out a lot of MCMT errors, so I'm pretty certain the media cache is at fault here, but I can't seem to do anything about it since modifications to modules don't take.

Anyone think they know of a method to force it to write the changes?

Return to “Arch F3”

Who is online

Users browsing this forum: No registered users and 2 guests