Page 1 of 1

Error reading sector but can see data

Posted: 09.05.19, 09:41
by DCDL
Hi,

So im scanning this drive that has lots of black sectors. It looks like platter damage. Every 200 sectors there is about 5-10 black sectors.

When I double click some of these black sectors after a couple of tries they do eventually read and I can see data. The problem is that the sector colour does not change to green it always stays black, even though i can now see data. I've tried closing the task and re-reading over the sectors but it doesent work.
If i read the same sector again it still struggles to read, takes a couple of tries and then reads it again. Still the sector stays black!

Not all of the sectors do this so there is definitely bad sectors on the drive but I just wanted to know if anyone could shed some light onto why DE does not change the colour to green once its read the sector once.

Thanks,
Lawrence

Re: Error reading sector but can see data

Posted: 09.05.19, 16:06
by d_d_recovery
Have you tied making a submap of the black sectors and rereading them that way.
Does that change anything?
Also make sure the 'skip sectors on reading error' box is unchecked in the copying menu.

Re: Error reading sector but can see data

Posted: 10.05.19, 10:10
by DCDL
Hi,

thanks for reply.

Yeah tried all this:

skip sectors check boxes unticked
UDMA timeout at maximum
rereading sectors up to 10 times
reading only the black sectors from a map.

Still some of them will read when double clicking sector after it flashes about 3 or 4 time but colour doesent change so still seen as bad.

Waiting for our company to sort payment for tech support so cant ask acelab directly yet. Seems like more of a software issue rather than the drive itself! If it reads once the sector should always change colour surely!

Re: Error reading sector but can see data

Posted: 13.05.19, 18:28
by msurgeon
After creating submap of black sectors, change selected chains legend to "unread". Then re-try.

Re: Error reading sector but can see data

Posted: 05.06.19, 13:19
by DCDL
Hi,

it still reads black first time on all these sectors after clearing them and re-trying.

Ive found a solution but its not possible if too many sectors.

If I double click the sector to open sector edit, when it reads the data I cntl+A to select all, copy and paste the data without changing anything and then save the sector. Doing this changes the sector to be a modified sector.

I'm sure its a fault with pc-3000 so will contact tech support about it.

Thanks