Page 1 of 1

Hitachi ATMR clicking HDD

Posted: 18.10.12, 11:40
by ketil
I have a Hitachi ATMR 80GB HDD that I'm working on. I received it because it was clicking and couldn't be read, but I managed to start it and recover some of SA and some of HDD, before it broke down again with clicking. After that I never managed to start it again. I have tried heads map editing several times, with no luck. (When it's clicking, I can also hear that the motor is speeding up and slowing down.)

At this point I have 2 donors. I have swapped heads (actually heads, magnets, and all small parts) from donor #1. The HDD still clicks. I have tried hot swapping patient PCB from donor #2 to patient HDD. Donor#2 works fine with patient PCB, so it is healthy. On my first attempt, the HDD didn't click after hot swap, but PC3000 thought the drive was password protected, and neither donor nor patient was protected. I restarted and tried again, but since then it's only clicking with this approach.

I also tried more heads map editing in NVRAM. By completely changing heads map (03 02 01 00 instead of 00 01 02 03), I was able to make the disk stop clicking and exit BSY, but it didn't ID (as expected). I was able to start the utility with module info from original HDD profile and when I tried to verify modules, I could hear the disk working, but of course it couldn't read any modules. At this point, if I could reassign heads map without powering off the disk, I think perhaps I might be able to recover some data? But I haven't found out any way to do this.

I would also like to try smart hot swap, but first I need to understand where copy 0, copy 1 and factory copy of modules are stored. For some reason, copy 1 of most modules are not working. I thought copy 0 and copy 1 were on platter 0 and platter 1, but if I change heads map to "01 00 02 03", the HDD won't start. If I change heads map to "00 00 00 00", I still get success for modules copy 0 and many errors on modules copy 1. If the HDD overrides the heads map somehow when reading modules, as it seems when using "00 00 00 00", then I don't understand why heads map "01 00 02 03" fails.

Appreciate any feedback to get this disk working.

Re: Hitachi ATMR clicking HDD

Posted: 18.10.12, 14:40
by AJ2008
Do you have full copy of SA modules from copy 0 now?

Re: Hitachi ATMR clicking HDD

Posted: 18.10.12, 15:08
by ketil
No, not from the patient, but I have them from the donor. I did try to get a full copy from the patient when it worked, but I couldn't get all of them. RDM1 is missing, for example, which is important. I stored modules to both DB and profile, and in both places this module is missing. Here's a couple of screenshots of the module files I have from donor and patient, from the profile folder.
patient modules
patient-atmr-modules.png (44.76 KiB) Viewed 7417 times

donor modules
donor2-atmr-modules.png (109.08 KiB) Viewed 7417 times

Re: Hitachi ATMR clicking HDD

Posted: 18.10.12, 18:02
by ketil
Testing some more, the drive never stops clicking with NVRAM heads configured as "00 00 00 00" or "01 01 01 01", but if configured as "02 02 02 02" it stops after a while, and as "03 03 03 03" it stops almost immediately. Perhaps one option would be to use one of these configurations, and then try to write back the modules I have backed up. I can perhaps add modules from the donor where possible, or rebuild if that is possible. Then I can maybe acquire heads 02 and 03.

After that, I have one more headstack I can try to transplant, or try some other approach.


Re: Hitachi ATMR clicking HDD

Posted: 19.10.12, 11:45
by ketil
Is it possible to load modules manually into RAM from module backup files? When starting the disk utility, I can load resources from profile, but it only reads zone allocation and module directory, not all the modules themselves.

In the "Service information objects" tool, I can read modules by module or ABA, but I can also view and edit NVRAM and modules in RAM. Can I load the modules into RAM manually with this tool, one by one, and then maybe do a soft reset to reinitialise disk? I tried to view a module in RAM, and it shows all 00. Then I could load the correct .rpm from the profile, and it is inserted into my view, but should I click "Write data to HDD"? Does that write it to RAM or to SA?