Why would there be no modules or ID for a WD30EZRX?

Moderator: Maxim_TS


giventofly
Newbie
Posts: 1
Joined: 18.05.17
Reputation: 0 / (0)

Why would there be no modules or ID for a WD30EZRX?

Postby giventofly » 09.01.20, 22:24

Customer lost native PCB for this drive, it's a WD30EZRX-00D8PB0. I guess they thought they needed to change the controller board because they couldn't gain access to the drive. It came out of a MyBook enclosure, so I'm sure it's encrypted, which is why they couldn't access the data. Anyway, they threw away the old PCB. So this drive arrived with no controller.

I had one off of a parts drive here, and the drive spins up, no ERR lights. However, I had to use a loader to read SA SPT. It wouldn't do anything without one.

Now it detects SA SPT, but the ID is still generic, and after that the output looks like this

Techno mode key
Techno mode key......................... : Ok

RAM:
HDD Info reading........................ : Ok
Heads number............................ : 6
Cyl Count............................... : 256

Zone allocation table................... : HDDs RAM reading error Device Error Detected: "SCT INVALID FUNCTION CODE"

ROM:
Read ROM................................ : Ok
ROM Data size........................... : 512 Kb
Flash ROM dir reading................... : Ok
Flash ROM dir reading (Ext)............. : Ok (Active)
Modules directory address............... : 173 608
SA regions address...................... : by default
Module 02 access........................ : Granted
SA Translator loading................... : Ok

ROM Modules:
ROM version............................. : 01.6AC
ROM F/W version......................... : 0001006A
Overlay F/W version..................... : 01.6BC
Servo F/W version....................... : 02.63

Heads configuration..................... : by map
Heads number............................ : 6
Heads number in use..................... : 6
Switched off heads...................... : No
Heads map............................... : 0,1,2,3,4,5

Service area:
Permanent overlay....................... : Not loaded
SA dir reading (ID)..................... : FM ERR HEADER II SIGNATURE INVALID

SA dir reading (ABA/CHS)................ : Ok
SA Access............................... : NONE

Configuration reading................... : Module 02 not found


And if I go in to try and read the modules, there are none there. It's just a blank window. Any idea what could be causing this? I don't delve into these firmware issues much, so I feel like I might be missing a step.

User avatar
d_d_recovery
Newbie
Posts: 46
Joined: 20.03.19
Reputation: 1 / (9)

Re: Why would there be no modules or ID for a WD30EZRX?

Postby d_d_recovery » 09.01.20, 22:52

You need to find the matching ROM with the same FW to your original ROM, or at least close enough to get SA access. Looks like this ROM is not compatible. It can help by sourcing donor FW with as close a SN as you can. This will give you the best chance. Check out HDDSurgerys firmware database.


Return to “WD Marvell”

Who is online

Users browsing this forum: No registered users and 0 guests